ربط روتر سيسكو مع مودم الانترنت !


السلام عليكم و رحمة الله و بركاته

تحية طيبة اخواني زوار مدونة الخبراء العرب

موضوع اليوم , هو موضوع بناء على طلبات و تسائلات الكثير من طلاب الشبكات وهو عن كيفية ربط روتر سيسكو مع مودم الانترنت او الـ ADSL

في الحقيقة الموضوع سهل جدا و سوف اقوم بشرحة بطريقة مختصرة جدا

مخطط الشبكة

مثل ما هو موضح ثلاث شبكات متصلة بالـ R1  و الروتر متصل بـ Speedtouch Modem  و يعتبر هذا المودم هو بوابتنا للانترنت في الشبكة المطروحة

نقاط الابس لدى الغالب !

  •  كيف تستطيع الشبكات الخروج عن طريق الروتر علما ان الروتر مربوط بمودم و عنوان المودم Privet Address و ليس Public Address
  • عملية الـ Network Address Translation كيف تتم في شكبة مثل هذه

في الحقيقة في هذه الشبكة سوف تتم عملية الـ NAT مرتين وليس مرة واحده فقط !!

الشبكات المربوطة بالـ R1 هي 10.1.1.0 ,10.2.2.0 , 10.3.3.0 و تخرج عن الى 192.168.1.0 هنا تحصل عملية الـ NAT الاولى , و المودم يقوم بدورة عمل الـ NAT للمرة الثانية حتى يحصل الخروج للانترنت

التطبيق 

قم بأعطاء الـ R1 عنوان IP من نفس المدى او الـ Range للمودم المستخدم او قم بتغير الـ Range الخاص بالمودم الى الـ Range المستخدم في الشبكة !

و من ثم نقوم بعمل Static Route لتوجيه الـ Requests الى مودم الانترنت و المودم بدوره يقوم بتوجية الى الانترنت 

ip route 0.0.0.0 0.0.0.0 192.168.1.254

اما الان نقوم بعمل NAT لتحويل عناوين الشبكات الكأنه خلف الـ R1 الى عنوان المودم و من ثم المودم سوف يضن ان هذه الشبكات كمستخدم مربوط به مباشرتا و سوف يوجهه للانترنت 

لعمل الـ NAT في البداية قم بتنفيذ الامر التالي في الـ Interface level للشبكات التالية 10.1.1.0 ,10.2.2.0 , 10.3.3.0 

R1(config)#int f0/0
R1(config-if)#ip nat inside

بعد تنفيذ هذا الامر قم بعمل العكس على الـ Interface المربوط بالمودم 

 

R1(config)#int f1/2

R1(config-if)#ip address 192.168.1.30 255.255.255.0
R1(config-if)#ip nat outside

التالي هو عمل Access List يضم الشبكات الثلاثة السابقة  

access-list 7 permit 10.1.1.0 0.0.0.255
access-list 7 permit 10.2.2.0 0.0.0.255
access-list 7 permit 10.3.3.0 0.0.0.255

والان نقوم بتطبيق الامر التالي ..

ip nat inside source list 7 pool ovrld overload

بهذه الحالة نكون قد انتهينا من العملية بشكل كامل و كل ما عليك فعله للتحقق ان العملية تتم بشكل جديد هو استخدام اوامر التحقق التالية 

Ping google.com

ping google.com source 10.1.1.1

or 

R1# ping

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.1.1

ملاحظة : غير مدعومة في بعض الـ ISO
R1#show ip nat translations

تقبوا مني اطيب تحية ,,
اخوكم /سعيد بافقاس 
Advertisements
    • waseem5
    • مارس 30th, 2012

    يعطيك العافيه

    موضوع قيم

    • abu ail
    • مارس 31st, 2012

    يعيك العافية مبرمج المستحيل
    شرح جدا جدا رااااااااااااائئع
    جزاك الله خير لانه بجد الكثر يحتاجه

    بانتظار جديدك المشوق

    شكرا لك ..

    • CRACKER
    • مايو 14th, 2012

    لماذا نقم بإدخال الامر ip nat pool
    هل سيقوم الراوتر بعمل translation تلقائياً لرانج الاي بيات الي عملنالها اكسس لست .. الرجاء توضيح هده النقطة

    • CRACKER
    • مايو 15th, 2012

    عذراً لكن انا لم اسأل عن هذا الامر
    ip nat inside source list 7 pool ovrld overload

    اسف لم اوضح السؤال جيداً … انا اقصد لماذا لم نعطي الراواتر رانج اي بي real ip حتي يقوم بعملية الترجمة من static ip الي real ip عند طلب الانترنت .. يعني من اين الراوتر راح يجيب ال real ip في هذا السيناريو مثلا كالتالي :
    ip nat pool CRACKER 200.0.0.1 200.0.0.60 0 netmask 255.255.255.248

    • الان فهمت سؤالك ,, ولاكن لو راجعت الرسمة المطروحه .. ستجد انا عملنا عميلية الـ NAT من رنج Privet to Privet حيث اننا متصلين بمودم الانترنت بعنوان خاص .. و من ثم سوف يقوم مودم الانترنت بعمل NAT مره اخرى من العنوان الـ Privet to Public و من ثم سوف نقوم بالاتصال بالانترنت ..

    • CRACKER
    • مايو 16th, 2012

    انا عارف مادا سيفعل الـ ADSL تقوم شركة الاتصالات بنزويده بـ IP متغير غير ثابت ويتغير عندما نقوم بعمل RESET للمودم .. يعني المودم سيقوم بترجمة الـ PRIVATE IP القادم من الراوتر الي الـ IP المؤقت الموجود بالمودم .. بس حبيت اسمع الاجابة النمودجية منك لاني ملخبط شوي بمحلات

    • yassine
    • يونيو 20th, 2012

    بارك الله فيك اخي سعيد و عنذي اضافة بسيطة ستكون احسن من كتابة

    access-list 7 permit 10.1.1.0 0.0.0.255
    access-list 7 permit 10.2.2.0 0.0.0.255
    access-list 7 permit 10.3.3.0 0.0.0.255

    فقط نكتب

    access-list 7 permit 10.1.1.0 0.0.2.255

    سيكون احسن

    و جزاك الله كل خير

    • بارك الله فيك اخ ياسين .. تشكر على مداخلتك القيمة ..
      تصحيح :
      سوف يكون بالشكل التالي
      access-list 7 permit 10.1.1.0 0.0.3.255

      تحياتي ..
      سعيد بافقاس

  1. No trackbacks yet.

اترك رد

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

WordPress.com Logo

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   / تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   / تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   / تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   / تغيير )

Connecting to %s